programmers of Masto, which do you find easier to read?

1: filtered = _filterNumericArrayKeys(array)
2: filtered = array.filter(function($key, $val) { return isInt($key) })

@noiob filter for me! because that way you can see exactly what the filter is doing rather than relying on the name communicating the edge cases well~

though i personally also like to break lambdas into multiple lines so it's easy to find the body of the lambda without scanning the rest of the line:

array.filter(function($key, $val) {
return isInt($key);
})
Sign in to participate in the conversation
Awoo Space

Awoo.space is a Mastodon instance where members can rely on a team of moderators to help resolve conflict, and limits federation with other instances using a specific access list to minimize abuse.

While mature content is allowed here, we strongly believe in being able to choose to engage with content on your own terms, so please make sure to put mature and potentially sensitive content behind the CW feature with enough description that people know what it's about.

Before signing up, please read our community guidelines. While it's a very broad swath of topics it covers, please do your best! We believe that as long as you're putting forth genuine effort to limit harm you might cause – even if you haven't read the document – you'll be okay!